
General Information
About the Bucket
Registering Your Copy

Creating Tab
Creating Tab
The Toolbox
Adding Rhythm
Sound
Customizing Your Tab Layout

Printing
Exporting Tab
Importing Tab
Saving Your Work



About The Bucket
I've grown tired of ASCII tab.    That's how this all started.    ASCII tab serves a purpose and is great 
for exchanging tab via email, but let's face it, it's hard to edit and hard to read.
One night, I sat down and started hacking away.    Three months and a whole lot of hours later, I had 
The Bucket 'o Tab.    With it, editing tab is easy, and the printed results look great.
I'd love to see people start exchanging .BOT files, but barring that, The Bucket also does a nice job 
of exporting ASCII tab, as well as reading it in.    Put that together with the ability to play back your 
transcriptions, and you've got a pretty neat tool.

Acknowledgements
The Bucket 'o Tab was written with Visual Basic 3.0, Professional Edition. Sounds were sampled with
GoldWave, a fantastic shareware sound editing utility. The "Bucket 'o Notes" font was created with 
CorelTrace and CorelDraw 3.0.    This Helpfile was created with Visual Help 2.0f, another great 
shareware application.
Thanks to Brett Foster for ToolButton. Thanks also to my beta testers (read: feature requesters) for 
their time and valuable input.

The Future...
I don't consider The Bucket done.    The next version will have lots of new features, including more 
objects and MIDI support.
Of course, the next version is much more likely to happen if I get some response from this one, so 
PLEASE register your copy!

Find a bug?    Want a feature?
Great!    Bug reports, feature requests, and feedback are gratefully accepted.    E-mail them to 
gse@ocsystems.com.

Onward through the fog!

Scott Evans



Registration Information
This program is NOT freeware.    After trying it for 20 days, you are expected to register your copy.    
Please support the shareware concept and do so!

Registration fee is $25 US.    Send a check or money order, along with your address and preferred 
media (3.5" or 5.25" disk) to:
    Scott Evans
    3176-B5 Summit Square Drive
    Oakton, VA    22124

Registered users may receive the next shareware version of Bucket 'o Tab for the cost of media and 
shipping, and will be notified of new products.
The registered version of the software also includes:
n Sound support:    Hear your tab as you enter it!    You can also play back your tab after entering it 

to check for correctness.    Includes sampled bass and guitar (both clean and distorted) sounds.
n The "Created with..." message does not appear at the bottom of every printed page.



Creating Tab
Creating tab is easy:
n Select "New" under the File pulldown if you want to change the number of strings in the tab.
n Use the UP and DOWN cursor keys to select the string on which notes are placed.
n Type a number to enter a note on that fret.    For frets above 9, press shift and the first number of 

the fret.    So, for example, for fret 16 type shift-1, 6.    For fret 24, type shift-2, 6.
n Use the toolbox or keyboard shortcuts to enter other tab objects, such as repeats, hammerons, 

slides, comments, and so on.
You can also highlight sections of tab with the mouse and perform cut/copy/paste operations on 
those sections.
See also:
Adding a Title
Entering Chords
Entering Text
The Toolbox
Using Rhythm
Sound
Saving Tab



Adding a Title
To edit the title of your tab, choose "Title/Comments..." from the Options menu, or click on the title 

window at the bottom left of the main screen.    

There are three fields in the Title dialog:
1 The title appears centered at the top of the first printed page.    It may be only one line long.
2 The subtitle appears centered below the title on the first printed page.    It may be any number of 

lines.    The subtitle generally contains the name of the artist whose music is transcribed.
3 The "comments" field appears right-justified under the subtitle.    It may be any number of lines.    

This field is generally used for credits, such as "Bass transcription by John Smith".
The fonts that these in which these fields are printed may be customized.
See also:
Customizing Tab Layout



Customizing Layout
The look of your tab, both on-screen and printed, is flexible.    The "Document Layout" dialog is 
available under the "Options" pulldown.
As you change the values in this dialog, the results are visible in the "Sample Tab" area.    If "Save As
Default" is checked when you click OK, the current layout settings will be used for any new 
documents.

Tab Spacing
There are three types of tab spacing that may be adjusted with the sliders at the bottom right of the 
dialog.    These adjustments apply to the screen and to printed tab.
n Note spacing: the amount of space between notes.
n Line spacing: the amount of space between each line in a staff.
n Staff spacing: the distance between staves.

Font
Clicking the "Font..." button will load your installed fonts and add a font selection list to the layout 
dialog (this button is provided because loading all the available fonts can be slow on some systems).
There are five different objects whose fonts you can specify.    Select the object type with the 
pulldown above the font list.
n Heading, Title: the title that appears centered at the top of the first page of printed tab.
n Heading, Subtitle: the tex that appears centered on the first page under the title.
n Heading, Comments: comments that appera right-justified under the subtitle.
n Tablature: the notes of the tab.
n Text within tab: text objects that appear in tab.
When you select one of the first three types of object, a sample heading is shown to display the 
results of your edits.    When you select one of the last two, two lines of sample tab are shown with a 
sample text object.
Font modifications affect both screen display and printed tab ("heading" fonts only affect printed tab).

Color
The "Tab Color" and "Staff Color" dialogs allow you to change the color of your tab notes and staves 
on-screen.    Note that these have no effect on printed tab.

See also:
Adding a Title
Printing Rhythms
Printing Tab



Printing Rhythms
Unfortunately, printing rhythms is not as simple as displaying them on the screen.    To properly print 
rhythms you need a musical symbols font.    The Bucket distribution includes a TrueType font called 
"Bucket 'o Notes" that you can use if you do not have another music symbols font.
To support the variety of symbols fonts out there, the mapping of rhythms to characters is completely 
user-specifiable.    For instance, the "Bucket 'o Notes" font uses "Q" for a quarter rest, but another 
font may use "4".

Editing the Rhythm Character Map
To edit the character mapping and select the font to be used for printing rhythms, use the "Rhythm 
Font" dialog (available under the "Options" pulldown).
Use the "character mapping" section of the dialog to specify which letters should be used to 
represent each type of rhythm and rest (triplets are handled by The Bucket).    A rhythm may map to 
more than one character (for instance, a dotted quarter note may be "q.").
As you change the character mapping, your changes will be shown in the sample area.

Resetting the Character Map
The "Reset Map" button sets the character map to the proper map for the "Bucket 'o Notes" font.

See also:
Printing Tab
Using Rhythm



Printing Tab

One of the nicest things about The Bucket is its ability to print professional-looking tab.
To print your tab, select "Print..." from the File menu, or click the printer button on the button bar.

Fonts
You can select the fonts used to print your tab in the "Layout" dialog.    If you are including rhythms in 
your printout, be sure that your rhythm font and character mapping are set properly (use the "Rhythm
Font" dialog).

Printing Options
Before you print your tab, you will be presented with a list of options for customizing the look of the 
tab.
n Break lines at barlines: Some people don't like line breaks in the middle of bars.    This option will 

prevent this; it also "right-justifies"    tab so every line goes to the end of the staff.    Using this 
feature is recommended.

n Attach tab explanation page:    This option causes an extra page to be printed containing an 
explanation of the symbols used in the tab.

n Include rhythm: Prints rhythmic notation above each staff. If you use the option, make sure that 
you have the proper font and character mapping selected.

n Text Position: Text objects may be placed above or below the staves.    If you are including 
rhythm in your tab, it's a good idea to place the text below the staves since it may interfere with 
your rhythmic notation otherwise.

See also:
Customizing Layout
Printing Rhythms



Using Rhythm

If you like, you can add rhythmic notation to your tab.
To add rhythm, select a rhythmic value from the Rhythm Toolbox (see below).    All notes, chords, 
rests, and ghost notes that you add while a rhythm is selected will have that rhythmic value; you will 
see the rhythm appear above the tabbed note:

Adding Rhythm to Existing Tab
You can also change the rhythm of existing tab (or, if the tab has no rhythm, add it) without changing 
the tab itself.    To do this, select the desierd rhythm with the rhythm toolbox and click on the desired 
note with the RIGHT mouse button.

The Rhythm Toolbox
The rhythm toolbox is similar to the object toolbox.    You can use it to set the current rhythm, or you 
can use the keyboard shortcuts shown on each button (note that these shortcuts are all control key 
sequences; for instance, whole note is ctrl-w). You can toggle it on and off by checking "Rhythm 
Toolbox" in the "Options" pulldown.

The current rhythm may be a whole, half, quarter, eighth, or sixteenth note. The bottom two buttons 
are for dotted notes and triplets, respectively (triplets appear with a small "3" next to the note).
Remeber that you can exclude rhythmic notation when printing your tab, if you like.
See also:
Printing Rhythms
Printing Tab



Entering Chords

Entering chords is only slightly different from entering single notes.
When you press "c" or click the chord button in the toolbox, you are presented with the Chord Entry 
window:

Enter notes in this window in the same manner as you do single notes on the staff (press SPACE to 
clear a line).    The blue arrow points at the current string; just as with the regular staff, use the UP 
and DOWN cursor keys or the mouse to change strings.    When you finish creating the chord, click 
the OK button.    If you have a rhythm selected, it will appear over the chord.
To edit an existing chord, double-click on it to bring up the chord window.

See also:
Creating Tab
Using Rhythm



Entering Text

Tab is much easier to use when it includes comments, such as lyric snippets, song times, and so on.
To enter a text comment, press "t" or click the text button in the toolbox.    You will be prompted to 
enter the text.    Text appears in your tab as such:

You can select the font used to print text comments.
See also:
Customizing Tab Layout



The Toolbox
The toolbox is one way to enter tab objects other than notes.    You can toggle the toolbox on and off 
by checking Toolbox under the Options pulldown.
Clicking a button in the toolbox causes that object to be inserted at the current cursor position.
The toolbox functions are as follows:

Notice that each button has a letter in the bottom left corner.    This is the object's keyboard shortcut 
-- you can also enter the object by pressing this key (which turns out to be much more efficient than 
using the toolbox).
See also:
Entering Chords
Entering Text
Using Rhythm



Sound

Registered versions of The Bucket support sound.
When you install the registered version, you may install any or all of three possible sound collections:
bass, clean guitar, and distorted guitar.    These collections contain short 16-bit mono samples of 
each note of the guitar.    Of course, you need a 16-bit compatible sound card to hear these samples.

Selecting a Sound Collection
You can choose a sound collection by selecting "Select..." from the Sound pulldown. You can also 
choose a sound collection when you create a new file (from the File pulldown or the button bar).

Using Sound
n While entering tab: While entering tab, enabling sound allows you to hear notes you enter them. 

This is extremely useful, as it lets you catch errors as you go.
n Playing back tab: Click the play button on the buttonbar (or F5) to begin playback at the current 

cursor position.    Since there is some overhead involved with playing samples, the rhythm may 
not sound exactly correct, but it's certainly close enough to tell if your rhythm is correct.    This is 
a great way to check tab for correctness after entering it.

To stop playback, press the stop button, or press F6.

Playback speed can be changed with the tempo slider that appears while tab is being played.

Notes
n For chords, only the root of the chord is played since multiple .WAV files cannot be played 

simultaneously.
n Notes without a specified rhythm are played as if they were eighth notes.



Saving Tab

To save your tab, click the disk button on the button bar, or select "Save" or "Save As..." from the File
pulldown.
BOT files are ASCII files, rather than binary files, in order to make them easy to exchange via email 
or the Internet.



Exporting Tab
So you've created some great tab, and you'd like to distribute over the Internet or through email.    If 
your friends don't have The Bucket (they should, but if they don't), you'll want to send them ASCII 
tab.
The Bucket creates very sharp-looking ASCII tab.    To use this feature, select "Export..." under the 
File pulldown.

Export to ASCII: Options
As with printed tab, you can customize the look of your ASCII tab.    The ASCII Export dialog provides
a number of options.
n Page Width: The number of characters in each line of tab.    80 is the most common value.
n Object Spacing: The number of characters between each note and object.    This is similar to the 

"Tab Spacing" selection in the Document Layout window.    2 produces nice legible tab.
n Break lines at barlines: Some people prefer not to have a line break in the middle of a bar.    This 

option will prevent just that, though it does not "right-justify" your tab as the equivalent printing 
option does. The result is a "ragged" looking right margin.

n Include tablature explanation: If this box is selected, a number of lines will be added at the end of
the exported tab explaining the symbols used.    It's nice to include this explanation when 
distributing tab.

n Include rhythm: Some people prefer not to include rhythm in ASCII tab. In ASCII tab, rhythms are
printed as letters: "e" for eighth note, "E" for dotted eighth, and so on.

n Text position: Text objects may be placed above or below the staves.    If you are including 
rhythm in your tab, it's a good idea to place the text below the staves since it may interfere with 
your rhythmic notation otherwise.

See also:
Importing Tab
Saving Tab



Importing Tab
The Bucket allows you to import tablature from various file formats.    This turns out to be a very 
useful feature. Imagine getting some blah-looking ASCII tab via email or the Internet -- just import it 
into BOT and print a fantastic looking version for your use, or play it back to hear how it should 
sound!
To import tab, click the "Import..." selection under the "File" pulldown.    You will be asked to choose 
which type of file you wish to import, then prompted for a filename.
If The Bucket doesn't have an import filter you'd like to see, let me know!    (see "About The Bucket")

ASCII Tab
You can import an ordinary ASCII tab file (such as those often found on the Internet).    The filter 
works well, though there are some guidelines to follow in order to obtain the best results.
n If the tab itself is prefixed or suffixed by non-tablature information (such as explanatory text), be 

sure that it does not contain dashes or other characters that the filter may interpret as tab.    It's 
easiest to just remove any header from the file before importing it.

n The filter doesn't import rhythmic information (yet).
n The filter recognizes a number of common ASCII notations.    However, there are certainly some 

that it will interpret incorrectly.    If you have an object in an ASCII file that will not import properly, 
try changing that object's notation to another common one.

Mario D'Allessio's Bass Tab Creator
A big relief to many is that The Bucket imports .BTC files.    BTC supports a few objects (such as ties)
that The Bucket does not, so these objects are ignored.    However, rhythms are supported.

See also:
Exporting Tab



ASCII tab
Tablature created with ASCII characters.    Lines are made of dashes, a slash is used for a slide, and so 
on.



keyboard shortcuts
A quicker method of entering objects than using the toolbox.    Each object's keyboard equivalent is 
shown on the toolbox.



sound collection
A set of samples.






